Join Today
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Thanks (Given)
    3
    Thanks (Received)
    16

    Default Built-in e-mail client for Outlook.com started throwing warning

    On my N97mini, for a long time, I successfully used built-in e-mail client for outlook.com, but, a few days ago, it started throwing a warning.
    Warning say's: "Website has sent a certificate with different website name than requested" and two options: "accept" and "back". So, naturally, I select "Accept" and "Accept permanently" but this warning continues to appear over and over again.

    I went to Settings->Phone->Phone mgmt.->Security settings->Certificate managment "Trusted site certificates" and looked the one that stands for "*.hotmail.com" (because it issused for two sites:*.hotmail.com and imap-mail.outlook.com)
    All look's fine (valid date was 24/04/2016 etc.)
    Then I looked for issuer, it was "GlobalSign Organisation Validation CA - G2, GlobalSign nv-sa, BE"

    Well, I went to Settings->Phone->Phone mgmt.->Security settings->Certificate managment "Authority certificates" and looked for GlobalSign Root CA certificate and it gives me an error "certificate expired" when I pressed on it.

    So I deleted that expired certificate and googled for new one. Found one at https://support.globalsign.com/custo...t-certificates (top most, button "Download Root-R1 (Binary/DER Encoded)" ) downloaded it (file: Root-R1.crt).
    I was doing that on my PC, because built-in phone web browser give me "not found error" when I pushed download button. So I end up with copying that file, via Nokia PC Suite, to the phone mass memory folder, what I can access with built-in phone File mgr.(app) too.

    On the phone, I've started File mgr. app, navigated to folder where I've been placed certifiate file (Root-R1.crt) and clicked on it. Went thru "Save Sertificate dialog" (mark "Internet" and "Online certif.check", not marked "VPN", because same settings was with old certificate) get "the certificate was successfully saved" message or something similar.

    And now, my built in e-mail client work's fine with outlook.com mail (imap-mail.outlook.com) without throwing warning message.

    I Hope this helps someone.

  2. Thanks trajkopetko, tphg thanked for this post
  3. #2
    Member tphg's Avatar
    Join Date
    Apr 2009
    Posts
    78
    Thanks (Given)
    193
    Thanks (Received)
    11

    Default

    Quote Originally Posted by ivanosivan View Post
    On my N97mini, for a long time, I successfully used built-in e-mail client for outlook.com, but, a few days ago, it started throwing a warning.
    Warning say's: "Website has sent a certificate with different website name than requested" and two options: "accept" and "back". So, naturally, I select "Accept" and "Accept permanently" but this warning continues to appear over and over again.

    I went to Settings->Phone->Phone mgmt.->Security settings->Certificate managment "Trusted site certificates" and looked the one that stands for "*.hotmail.com" (because it issused for two sites:*.hotmail.com and imap-mail.outlook.com)
    All look's fine (valid date was 24/04/2016 etc.)
    Then I looked for issuer, it was "GlobalSign Organisation Validation CA - G2, GlobalSign nv-sa, BE"

    Well, I went to Settings->Phone->Phone mgmt.->Security settings->Certificate managment "Authority certificates" and looked for GlobalSign Root CA certificate and it gives me an error "certificate expired" when I pressed on it.

    So I deleted that expired certificate and googled for new one. Found one at https://support.globalsign.com/custo...t-certificates (top most, button "Download Root-R1 (Binary/DER Encoded)" ) downloaded it (file: Root-R1.crt).
    I was doing that on my PC, because built-in phone web browser give me "not found error" when I pushed download button. So I end up with copying that file, via Nokia PC Suite, to the phone mass memory folder, what I can access with built-in phone File mgr.(app) too.

    On the phone, I've started File mgr. app, navigated to folder where I've been placed certifiate file (Root-R1.crt) and clicked on it. Went thru "Save Sertificate dialog" (mark "Internet" and "Online certif.check", not marked "VPN", because same settings was with old certificate) get "the certificate was successfully saved" message or something similar.

    And now, my built in e-mail client work's fine with outlook.com mail (imap-mail.outlook.com) without throwing warning message.

    I Hope this helps someone.
    I tried to install the cert, but it shows error that the label Global Sign Root CA is in use and asked to enter new label. Someone know how to solve it? Thanks in advance.
    --------------------------------
    P/S: Sorry that I haven't read through your instruction above that the old cert must be delete first. Now I could install it. Anyway, thank you so much for your useful sharing.
    But I still could not check my email, neither with Nokia nor Profimail app.
    Last edited by tphg; 05-19-2017 at 08:38 AM.

  4. #3
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Thanks (Given)
    3
    Thanks (Received)
    16

    Default

    Yes the old cert must be deleted first.
    I attached a screenshot of my current mail settings for the embedded mail client for outlook.com (Also have gmail but its almost the same ).
    And also the certificate mentioned in my initial message (the one that I actually used). But in my case cert error was clear.
    outlook_settings_nokia.jpg
    Attached Files Attached Files

  5. Thanks tphg thanked for this post
  6. #4
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Thanks (Given)
    3
    Thanks (Received)
    16

    Default

    You can also check the mailbox settings on the site https://outlook.live.com itself, attached a screenshot
    outlook_site_settings.jpg

  7. Thanks tphg thanked for this post
  8. #5
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Thanks (Given)
    3
    Thanks (Received)
    16

    Default

    As for S60 3rd Edition FP2 you can try to install networking_improvements update, I attached it (source)
    networking_improvements_2924.jpg
    Attached Files Attached Files
    Last edited by ivanosivan; 05-27-2017 at 07:16 PM. Reason: screnshot with sis contents details added

  9. Thanks tphg thanked for this post

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •