Join Today
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Dec 2008
    Posts
    12,253
    Thanks (Given)
    0
    Thanks (Received)
    26

    Default Guide: How to fix Cydia problems / errors


    Heres a guide on how to fix Cydia problems or error that u may get while using Cydia on jailbroken iPhone / iPod Touch. Enjoy!
    <span style="text-decoration: underline;">Identify the Problem:</span>This is probably a good place to start ... follow the steps to see if you can determine the problem with your Cydia: <div><div><div>1) Open Terminal on the device or through SSH.
    2) Type the following:
    <span style="color: red;">su
    alpine
    apt-get update</span>
    3) Read the error message.
    </div></div></div>
    Sometimes just running the update command will fix the issue!
    <span style="text-decoration: underline;"></span>Cydia Crash on Load:<div><div><div>1) SSH into your device.
    2) Navigate to the /var/lib/apt/lists/ folder.
    3) Delete everything EXCEPT the partial folder.
    4) Reboot.</div></div></div>
    Another possible fix is to SSH into root/private/ect/apt/sources.list.d and remove all entries except saurik.list.
    This will delete all your manually added repos. (Thanks to neyzcorp for this fix)
    <span style="text-decoration: underline;"></span>Cydia Won't Add a Repo:
    There are very few possible explanations, here are a few:
    1) The repo is down, check the forums for more information.
    2) You typed it wrong, many people forget to put the / at the end of a repo url.
    3) You aren't connect to a network ... pretty self explanatory.
    <span style="text-decoration: underline;">Source Error:</span>
    A common error message would be Bzip2 error or the fact that a source is not functioning correctly.
    <span style="color: red;">IF A REPO ONLY ACCEPTS ONE DEVICE PER ACCOUNT YOU WILL GET THIS MESSAGE IF YOU ADD MORE THAN ONE DEVICE (our repo is like this)</span>
    If you cannot remove the source from Cydia or the problem persists, try this: <div><div><div>1) SSH into your device.
    2) Navigate to the /etc/apt/ folder.
    3) Backup the cydia.list OR sources.list.d file.
    4) Edit the cydia.list OR sources.list.d file with a text editor and remove the entry related to the problematic source.
    5) Reboot.</div></div></div><span style="text-decoration: underline;">
    Crash After "Reloading Data":
    </span>
    If Cydia is crashing after the Reloading Data message then try this:
    (If you don't have terminal installed, use terminal through SSH) <div><div><div>1) Open Mobile Terminal/Terminal via SSH.
    2) Type:
    <span style="color: red;"> su
    alpine
    dpkg --configure -a</span>
    3) Reboot.
    </div></div></div>
    I am unsure that this is a valid fix but if you try it let me know the outcome please.
    <span style="text-decoration: underline;">
    Package Header Error:
    </span>
    If on startup, Cydia says there's an error with package headers do the following to fix it. <div><div><div>
    1) Open terminal and type:
    <span style="color: red;">su
    alpine
    dpkg --a configure</span>
    2) Respring just to make sure it reloads the data.<span style="text-decoration: underline;"></span></div></div></div><span style="text-decoration: underline;">Icon is not Visible:</span>
    If your Cydia icon disappeared after you installed a new package and restarting doesn't get it back, follow these steps: <div><div><div>1) SSH into /applications/cydia.app
    2) Copy the icon.png to your computer.
    3) Delete icon.png from the device
    4) Respring and a basic, white icon will appear for Cydia.
    5) Copy the icon.png back to /applications/cydia.app
    6) Respring and the normal icon should be there.</div></div></div><span style="text-decoration: underline;">
    Cyder:
    </span>
    Cyder is a progam for your computer that downloads and transfers packages/sources to your device.
    It also has other useful feature which may fix problems such as clearing the cache.
    To get it go here:
    <span style="text-decoration: underline;">A New Cache Fix:
    </span>
    If you are having problems with the cache and want to clear it try this new tool. There are 2 things you must install first though.
    1) FixCydiaCache here - download
    2) afc2add package from Cydia
    To fix the cache you must:
    1) Load FixCydiaCache and connect your iDevice to the PC
    2) Click on the only button that says “Fix My Cydia Cache!”
    <span style="text-decoration: underline;">Reinstall Cydia:</span>If you can't find a fix for the problem and you really want it fixed, then try reinstalling Cydia. <div><div><div>1) Open Terminal on your device or through SSH
    2) Type the following commands:
    <span style="color: red;">su
    alpine
    apt-get remove cydia
    apt-get install cydia</span>
    3) Reboot
    </div></div></div>
    Another method of reinstalling Cydia is: <div><div><div>1) Download Cydia (use google to find the link)
    2) SSH the package to /var/mobile on your device.
    3) Open Terminal and type the following:
    <span style="color: red;">su
    alpine
    dpkg -i cydia.deb</span>
    4) Reboot (twice sometimes)<span style="color: darkslateblue;"><span style="font-size: x-small;"><span style="color: red;"></span></span></span><span style="color: darkslateblue;"><span style="font-size: x-small;"><span style="color: red;">If none of the above worked then you will be forced to rejailbreak ... there is no other way!</span></span></span></div></div></div>
    [Thx NastyBen for the guide]
    <a href="http://dailyiphoneblog.com/2010/04/22/guide-how-to-fix-cydia-problems-errors/">

    [Read the original blog post]
    </a>
    testing

  2. #2
    Junior Member
    Join Date
    Aug 2009
    Posts
    1
    Thanks (Given)
    0
    Thanks (Received)
    0

    Default Re: Guide: How to fix Cydia problems / errors

    ...and what have i to do if i didn't install OpenSSH? My Cydia crashed on startup...

  3. #3
    helpful guided
    Guest

    Default Re: Guide: How to fix Cydia problems / errors

    My error was that my Cydia would crash on load. I ran the update command at the terminal and found the problem. I had to run the dpkg --configure -a manually. Afterwards when I restarted Cydia, I found that a program had not uninstalled correctly, namely, Backgrounder. It allowed me to force clear the app and now no problems. Thanks for the help.

  4. #4
    Junior Member
    Join Date
    Oct 2014
    Posts
    1
    Thanks (Given)
    0
    Thanks (Received)
    0

    Default

    I tried updating cydia from a website and it told me to open it in ifile and then hit install, but when I did it said it couldn't with an error code 256 and said this

    Executing Command: /usr/bin/dpkg -i "/var/mobile/Media/Downloads/cydia_1.0.3366-1_iphoneos-arm (1).deb"




    (Reading database ... 4130 files and directories currently installed.)
    Preparing to replace cydia 1.0.3366-1 (using .../cydia_1.0.3366-1_iphoneos-arm (1).deb) ...
    Unpacking replacement cydia ...
    dpkg: dependency problems prevent configuration of cydia:
    *apt7-lib (0.7.25.3-13) breaks cydia (<< 1.1.10) and is installed.
    * Version of cydia to be configured is 1.0.3366-1.
    dpkg: error processing cydia (--install):
    *dependency problems - leaving unconfigured
    Errors were encountered while processing:
    *cydia




    Finished with Result Code: 256
    I don't know what to do and I restarted my phone and now it won't open cydia at all .


 

Similar Threads

  1. About the forum database errors
    By phattrance in forum Forum News
    Replies: 41
    Last Post: 01-25-2011, 11:49 AM
  2. how do you delete cydia when cydia is not working?
    By pepe wicho in forum iPhone Forum
    Replies: 3
    Last Post: 04-16-2010, 12:26 AM
  3. Replies: 6
    Last Post: 03-21-2010, 05:23 PM
  4. Guide: Avoid Phone Startup Problems S60 v5
    By zymesh in forum Symbian S60v5 Forum
    Replies: 20
    Last Post: 01-26-2010, 05:41 AM
  5. 5800XM is laggy and gives errors after deleting python
    By spinkol in forum Symbian S60V5 Modding
    Replies: 5
    Last Post: 01-05-2010, 10:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •